We need this in order to redirect to correct section on home page.
Close

Frequently asked questions

What mobile phones are compatible with the Hyundai Auto Link

Hyundai Auto Link will work with OS versions:

- Android 5.0 (and above): compatible with all android phones that support 5.0 and above

- iOS 9.0 (and above): all iphones after iphone 5 (5, 5s, 6, 6+, 6s, SE, 7, 7+, 8, 8+, X)

See all frequently asked questions
Powered by Zendesk